Issue
The Archive button on a form link leads to the file saved in the Lasernet Archive. This button is active if an archived file exists.
However, in some cases, this button may be greyed out, even when an archived file exists.
In the following image, the Archive button is greyed out for a free text invoice on the All free text invoices list page:
Cause
The reason why the Archive button is not active, is that the archived file’s reference archive table is different from the data source on this form.
In the following image, the archived file’s reference archive table is the Customer invoice journal:
However, the form link with the Archive button is on the All free text invoices list page. The data source for this form is CustInvoiceTable.
Solution
The report’s Table for archive must be updated to match the data source on the form where you are trying to select the Archive button. To do so, follow these steps:
1. Set the CustInvoiceTable as the Table for archive.
2. Print the report again to create an archive file with a reference to the new Table for archive.
The Archive button is now active on the All free text invoices list page.
If you cannot locate the DataSource for the report, open the Query wizard and check the main table (for instance, if you are dealing with a custom report that is using the PurchTable, set the Table for archive to be PurchConfirmationRequestJour).
Typically, the Table for archive is set from the workspace where the report is run. For example, when running a record from Sales Confirmation, expect a relevant Table for archive to be there.
This information can be found by right-clicking a record and viewing the form information.
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